Login | Register


All times are UTC + 1 hour


It is currently Sat Apr 29, 2017 18:42 pm




Post new topic Reply to topic  [ 9 posts ] 
Author Message
PostPosted: Wed Jan 27, 2010 5:01 am 
User avatar

Joined: Tue Jan 08, 2008 23:34 pm
Posts: 23
Location: Australia
I've been downloading some user-made maps and playing on them in the single player mode.

There's one problem. Often, the AI sides-friend and foe alike-will simply stop doing anything. The workers will just stand around idle, and there won't be any raids on my base or attempts to take relics. This isn't the case in the beginning of a game, but it is nearly always the case by the end.

Why is this so?

I'm using the boosterpack version of Paraworld (1.05) in case that is any help.

_________________
Today is a beautiful day to be stomping on things! As a dinosaur, stomping is the best part of my day indeed!


Top
 Offline Profile  
 
PostPosted: Wed Jan 27, 2010 7:15 am 
- Admin -
User avatar

Joined: Sat Apr 18, 2009 14:17 pm
Posts: 1964
If you select random, the AI MAY become the state "Passive". If an AI is PASSIVE, it does not do anything ;)

_________________
I've never seen code like this.

CEP Moddb | CEP download
ParaWelt TicTacToe | Multiplayer TicTacToe/4 gewinnt/etc v1.2


Top
 Offline Profile  
 
PostPosted: Wed Jan 27, 2010 19:44 pm 
- Admin -
User avatar

Joined: Wed Jul 25, 2007 17:16 pm
Posts: 4895
Location: Germany
Does this happen with AI level 8-9 as well?

_________________
ICQ http://www.icq.com/people/327554363/


Top
 Offline Profile  
 
PostPosted: Wed Jan 27, 2010 19:47 pm 
- Admin -
User avatar

Joined: Sat Apr 18, 2009 14:17 pm
Posts: 1964
Yep

_________________
I've never seen code like this.

CEP Moddb | CEP download
ParaWelt TicTacToe | Multiplayer TicTacToe/4 gewinnt/etc v1.2


Top
 Offline Profile  
 
PostPosted: Wed Jan 27, 2010 20:56 pm 
- Admin -
User avatar

Joined: Wed Jul 25, 2007 17:16 pm
Posts: 4895
Location: Germany
ok

_________________
ICQ http://www.icq.com/people/327554363/


Top
 Offline Profile  
 
PostPosted: Thu Jan 28, 2010 2:27 am 
User avatar

Joined: Tue Jan 08, 2008 23:34 pm
Posts: 23
Location: Australia
Ah, so that's what it's been doing. I've been picking random all this time, so it makes sense.

_________________
Today is a beautiful day to be stomping on things! As a dinosaur, stomping is the best part of my day indeed!


Top
 Offline Profile  
 
PostPosted: Thu Jan 28, 2010 6:58 am 
- Admin -
User avatar

Joined: Sat Apr 18, 2009 14:17 pm
Posts: 1964
I mean random AI-Type (Aggressive/Defensive/etc) not random tribes, those are okay ;)

_________________
I've never seen code like this.

CEP Moddb | CEP download
ParaWelt TicTacToe | Multiplayer TicTacToe/4 gewinnt/etc v1.2


Top
 Offline Profile  
 
PostPosted: Sat Feb 05, 2011 21:46 pm 

Joined: Fri Jan 07, 2011 16:27 pm
Posts: 22
Have the same error sometimes if I play on custom map from Mappack.

At first I had a lot of problems with my enemies. Usually enemy AI tries to attack me in 2-5 minutes causing some problems in beginning. If not, it still makes some "bad things": builds towers right near my base, steals my resourses etc. But something started to happen on custom maps from time to time: AI not only sits still without any attempt to attack me, but do not show any signs of his presence - not even a single worker aproaches my base. I always thought that my enemy simply makes an army to destroy me, so I simply stay at my base for 10-15 minutes, go up to 3 or 4 epoch, create some brachs, mamoth or saltas and with a large army go to the enemy's base to find out that all that brachs I bought was just a waste of meat: looks like I play versus a real player who went away for a cup of tea. My enemy is still in T1, there are only few buildings and some workers. And I at the same time already managed to research 4th epoch. Strange.
And finally I found out what a hell is goind on. I started a 2V2 game on a custom map with an AI controlled teammate. His behavior was really strange. Firstly all his workers went for food, then (after the maximum was reached I think), for some tree, and then all teammate's workers started to stand still and do nothing. After 2 or 3 minutes all his army moved to fight some allosaurus, and lost. Workers, instead of building some barracks and farms to regain army, continued to do nothing.
I am 100% sure that that time AI's type was defensive, not passive. Also this never happens on default maps.

Have you ever seen errors like that and do you think it is possible to avoid problems described above?

Thanks.


Top
 Offline Profile  
 
PostPosted: Sat Feb 05, 2011 23:02 pm 
- Admin -
User avatar

Joined: Sat Apr 18, 2009 14:17 pm
Posts: 1964
Yes, unfortunately this happens on some maps. Reasons are, the place is too small, no ressources in the area... or just some other reason.
How to fix? I cant think of a fix for this. Just playing another mission. :( maybe clearing the cache helps?

_________________
I've never seen code like this.

CEP Moddb | CEP download
ParaWelt TicTacToe | Multiplayer TicTacToe/4 gewinnt/etc v1.2


Top
 Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: